Addressing Table

Objectives

Part 1: Verify Router Connectivity
Part 2: Configure GRE Tunnels
Part 3: Verify PC Connectivity

Scenario
You are the network administrator for a company that wants to set up a GRE tunnel to a remote office.

Part 1: Verify Router Connectivity
Step 1: Ping RA from RB.

a. Use the show IP interface brief command on RA to determine the IP address of the S0/0/0 port.

RA(config)#do show ip interface brief
Interface IP-Address OK? Method Status Protocol
GigabitEthernet0/0 192.168.1.1 YES manual up up
GigabitEthernet0/1 unassigned YES unset administratively down down
GigabitEthernet0/2 unassigned YES unset administratively down down
Serial0/0/0 64.103.211.2 YES manual up up
Serial0/0/1 unassigned YES unset administratively down down
Tunnel0 10.10.10.1 YES manual up up
Vlan1 unassigned YES unset administratively down down
RA(config)#

b. From RB ping the IP S0/0/0 address of RA.

RA#
RA#ping 64.103.211.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 64.103.211.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 2/4/13 ms

RA#

Step 2: Ping PCA from PCB.
Attempt to ping the IP address of PCA from PCB. We will repeat this test after configuring the GRE tunnel. What were the ping results? Why?

Part 2: Configure GRE Tunnels
Step 1: Configure the Tunnel 0 interface of RA.

a. Enter into the configuration mode for RA Tunnel 0.

RA(config)# interface tunnel 0

b. Set the IP address as indicated in the Addressing Table.

RA(config-if)# ip address 10.10.10.1 255.255.255.252

c. Set the source and destination for the endpoints of Tunnel 0.

RA(config-if)# tunnel source s0/0/0
RA(config-if)# tunnel destination 209.165.122.2

d. Configure Tunnel 0 to convey IP traffic over GRE.

RA(config-if)# tunnel mode gre ip

e. The Tunnel 0 interface should already be active.

RA(config-if)# no shutdown

Step 2: Configure the Tunnel 0 interface of RB.
Repeat Steps 1a – e with RB. Be sure to change the IP addressing as appropriate.

RB#config t
Enter configuration commands, one per line. End with CNTL/Z.
RB(config)#
RB(config)#interface tunnel 0
RB(config-if)#ip address 10.10.10.2 255.255.255.252
RB(config-if)#tunnel source s0/0/0
RB(config-if)#tunnel destination 64.103.211.2
RB(config-if)#tunnel mode gre ip
RB(config-if)#no shutdown
RB(config-if)#

Step 3: Configure a route for private IP traffic.

Establish a route between the 192.168.X.X networks using the 10.10.10.0/30 network as the destination.

  • Configure route on RA
    RA(config)# ip route 192.168.2.0 255.255.255.0 10.10.10.2
  • Configure route on RB
    RB(config)# ip route 192.168.1.0 255.255.255.0 10.10.10.1

Part 3: Verify Router Connectivity
Step 1: Ping PCA from PCB.

Attempt to ping the IP address of PCA from PCB. The ping should be successful.

Packet Tracer PC Command Line 1.0
C:>ping 192.168.2.2

Pinging 192.168.2.2 with 32 bytes of data:

Request timed out.
Reply from 192.168.2.2: bytes=32 time=22ms TTL=126
Reply from 192.168.2.2: bytes=32 time=12ms TTL=126
Reply from 192.168.2.2: bytes=32 time=14ms TTL=126

Ping statistics for 192.168.2.2:
Packets: Sent = 4, Received = 3, Lost = 1 (25% loss),
Approximate round trip times in milli-seconds:
Minimum = 12ms, Maximum = 22ms, Average = 16ms
C:>

Step 2: Trace the path from PCA to PCB.

C:>tracert 192.168.2.2

Tracing route to 192.168.2.2 over a maximum of 30 hops:

1 0 ms 0 ms 0 ms 192.168.1.1
2 2 ms 2 ms 10 ms 10.10.10.2
3 2 ms 15 ms 18 ms 192.168.2.2

Trace complete.

C:>

Attempt to trace the path from PCA to PCB. Note the lack of public IP addresses in the output.

For More Article | Share your ❤️ Buy me a ☕ Pls check out the sponsored

By Admin