Addressing Table

Switch Port Assignment Specifications

Objectives

Part 1: Configure VLANs
Part 2: Configure Rapid Spanning Tree PVST+ Load balancing
Part 3: Configure PortFast and BPDU Guard

Background
In this activity, you will configure VLANs and trunks, Rapid Spanning Tree PVST+, primary and secondary root bridges, and examine the configuration results. You will also optimize the network by configuring PortFast, and BPDU Guard on edge ports.

Part 1: Configure VLANs

Step 1: Enable the user ports on S2 in access mode.
Refer to the topology diagram to determine which switch ports on S2 are activated for end-user device access. These three ports will be configured for access mode and enabled with the no shutdown command.

S2(config)#int range fa0/6,fa0/11,fa0/18
S2(config-if-range)#switchport mode access
S2(config-if-range)#no sh
S2(config-if-range)#
%LINK-5-CHANGED: Interface FastEthernet0/6, changed state to up
%LINEPROTO-5-UPDOWN: Line protocol on Interface FastEthernet0/6, changed state to up

Step 2: Create VLANs.
Using the appropriate command, create VLANs 10, 20, 30, 40, 50, 60, 70, 80, and 99 on all of the switches.

A. Configure VLAN on S1

S1(config)#int vlan 10
S1(config-if)#vlan 10
S1(config-vlan)#vlan 20
S1(config-vlan)#vlan 30
S1(config-vlan)#vlan 40
S1(config-vlan)#vlan 50
S1(config-vlan)#vlan 60
S1(config-vlan)#vlan 70
S1(config-vlan)#vlan 80
S1(config-vlan)#vlan 99
%LINK-5-CHANGED: Interface Vlan10, changed state to up

B. Configure VLAN on S2

S2(config)#int vlan 10
S2(config-if)#vlan 10
S2(config-vlan)#vlan 20
S2(config-vlan)#vlan 30
S2(config-vlan)#vlan 40
S2(config-vlan)#vlan 50
S2(config-vlan)#vlan 60
S2(config-vlan)#vlan 70
S2(config-vlan)#vlan 80
S2(config-vlan)#vlan 99
%LINK-5-CHANGED: Interface Vlan10, changed state to up

C. Configure VLAN on S3

S3(config)#int vlan 10
S3(config-if)#vlan 10
S3(config-vlan)#vlan 20
S3(config-vlan)#vlan 30
S3(config-vlan)#vlan 40
S3(config-vlan)#vlan 50
S3(config-vlan)#vlan 60
S3(config-vlan)#vlan 70
S3(config-vlan)#vlan 80
S3(config-vlan)#vlan 99
%LINK-5-CHANGED: Interface Vlan10, changed state to up

Step 3: Assign VLANs to switch ports.
Port assignments are listed in the table at the beginning of the activity. Save your configurations after assigning switch ports to the VLANs.

S2(config)#int fa0/11
S2(config-if)#switchport access vlan 10
S2(config-if)#int fa0/18
S2(config-if)#switchport access vlan 20
S2(config-if)#int fa0/6
S2(config-if)#switchport access vlan 30

Step 4: Verify the VLANs.
Use the show vlan brief command on all switches to verify that all VLANs are registered in the VLAN table.

Step 5: Assign the trunks to native VLAN 99.
Use the appropriate command to configure ports F0/1 to F0/4 on each switch as trunk ports and assign these trunk ports to native VLAN 99.

S1(config)#int range fa0/1-4
S1(config-if-range)#switchport mode trunk
S1(config-if-range)#switchport trunk native vlan 99

S2(config)#int range fa0/1-4
S2(config-if-range)#switchport mode trunk
S2(config-if-range)#switchport trunk native vlan 99

S3(config)#int range fa0/1-4
S3(config-if-range)#switchport mode trunk
S3(config-if-range)#switchport trunk native vlan 99

Step 6: Configure the management interface on all three switches with an address.
Verify that the switches are correctly configured by pinging between them.

S1(config)#int vlan 99
S1(config-if)#ip add 172.17.99.11 255.255.255.0

S2(config)#int vlan 99
S2(config-if)#ip add 172.17.99.12 255.255.255.0

S3(config-if)#ip add 172.17.99.13 255.255.255.0
S3(config)#int vlan 99

Step 1: Configure STP mode.
Use the spanning-tree mode command to configure the switches to use rapid PVST as the STP mode.

S1(config)#spanning-tree mode rapid-pvst
S2(config)#spanning-tree mode rapid-pvst
S3(config)#spanning-tree mode rapid-pvst

Step 2: Configure Rapid Spanning Tree PVST+ load balancing.
Configure S1 to be the primary root for VLANs 1, 10, 30, 50, and 70. Configure S3 to be the primary root for VLANs 20, 40, 60, 80, and 99. Configure S2 to be the secondary root for all of the VLANs.

S1(config)#spanning-tree vlan 1,10,30,50,70 root primary
S2(config)#spanning-tree vlan 1,10,20,30,40,50,60,70,80,99 root secondary
S3(config)#spanning-tree vlan 20,40,60,80,99 root primary
S3(config)#%SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/2 on VLAN0099. Port consistency restored.
%SPANTREE-2-UNBLOCK_CONSIST_PORT: Unblocking FastEthernet0/2 on VLAN0001. Port consistency restored.

Verify your configurations by using the show spanning-tree command.

Part 3: Configure PortFast and BPDU Guard
Step 1: Configuring PortFast on S2.
PortFast causes a port to enter the forwarding state almost immediately by dramatically decreasing the time of the listening and learning states. PortFast minimizes the time it takes for the server or workstation to come online. Configure PortFast on S2 interfaces that are connected to PCs.

S2(config)#int range f0/6 , f0/11 , f0/18
S2(config-if-range)#spanning-tree portfast

Step 2: Configuring BPDU Guard on S2.

S2(config)#int range f0/6 , f0/11 , f0/18
S2(config-if-range)#spanning-tree bpduguard enable

The STP PortFast BPDU Guard enhancement allows network designers to enforce the STP domain borders and keep the active topology predictable. The devices behind the ports that have STP PortFast enabled are not able to influence the STP topology. At the reception of BPDUs, the BPDU Guard operation disables the port that has PortFast configured. The BPDU Guard transitions the port into the err-disable state, and a message appears on the console. Configure BPDU Guard on S2 interfaces that are connected to PCs.
Step 3: Verify your configuration.

Use the show run command to verify your configuration.

For More Articles | Share your ❤️ Buy me a ☕ Pls check out the sponsored

By Admin