Background / Scenario

As the number of switches in a network increases, the administration necessary to manage the VLANs and trunks can be challenging. To ease some of the VLAN and trunking configurations, VLAN trunking protocol (VTP) allows a network administrator to automate the management of VLANs. Trunk negotiation between network devices is managed by the Dynamic Trunking Protocol (DTP) and is automatically enabled on Catalyst 2960 and Catalyst 3560 switches.
In this activity, you will configure trunk links between the switches.

Addressing Table

Step 1: Verify VLAN configuration.

Verify the configured VLANs on the switches.
a. On S1, click the CLI tab. At the prompt, enter enable and enter the show VLAN brief command to verify the configured VLANs on S1.

S1# show vlan brief or do show vlan brief if you on configuration mode

S1>en
S1#config terminal
Enter configuration commands, one per line. End with CNTL/Z.
S1(config)#
S1(config)#do show vlan brief

VLAN Name Status Ports


1 default active Fa0/1, Fa0/2, Fa0/3, Fa0/4
Fa0/5, Fa0/6, Fa0/7, Fa0/8
Fa0/9, Fa0/10, Fa0/11, Fa0/12
Fa0/13, Fa0/14, Fa0/15, Fa0/16
Fa0/17, Fa0/18, Fa0/19, Fa0/20
Fa0/21, Fa0/22, Fa0/23, Fa0/24
Gig0/1, Gig0/2
99 Management active
999 VLAN0999 active
1002 fddi-default active
1003 token-ring-default active
1004 fddinet-default active
1005 trnet-default active
S1(config)#

b. Repeat step a. on S2 and S3. What VLANs are configured on the switches

Step 2: Configure Trunks on S1, S2, and S3.

Dynamic trunking protocol (DTP) manages the trunk links between Cisco switches. Currently, all the switch ports are in the default trunking mode, which is dynamic auto. In this step, you will change the trunking mode to dynamic desirable for the link between switches S1 and S2. For the link between switches S1 and S3, the link will be set as a static trunk. Use VLAN 999 as the native VLAN in this topology.
a. On switch S1 and switch S2, configure the trunk link to dynamic desirable on the GigabitEthernet 0/1 interface. The configuration of S1 is shown below.

S1#config t
Enter configuration commands, one per line. End with CNTL/Z.
S1(config)#interface g0/1
S1(config-if)#switchport mode dynamic desirable

b. For the trunk link between S1 and S3, configure a static trunk link on the GigabitEthernet 0/2 interface.

S1(config-if)#
S1(config-if)#int g0/2
S1(config-if)#switchport mode trunk
S1(config-if)#

S3>en
S3#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
S3(config)#
S3(config)#int g0/2
S3(config-if)#switchport mode trunk

c. Verify trunking is enabled on all the switches using the show interfaces trunk command.

S1(config-if)#
S1(config-if)#do show interface trunk
Port Mode Encapsulation Status Native vlan
Gig0/1 desirable n-802.1q trunking 1
Gig0/2 on 802.1q trunking 1

Port Vlans allowed on trunk
Gig0/1 1-1005
Gig0/2 1-1005

Port Vlans allowed and active in management domain
Gig0/1 1,99,999
Gig0/2 1,99,999

Port Vlans in spanning tree forwarding state and not pruned
Gig0/1 1,99,999
Gig0/2 1,99,999

S1(config-if)#

d. Configure VLAN 999 as the native VLAN for the trunk links on S1.

S1(config-if)#
S1(config-if)#int range g0/1 – 2
S1(config-if-range)#switchport trunk native vlan 999
S1(config-if-range)#%SPANTREE-2-RECV_PVID_ERR: Received BPDU with inconsistent peer vlan id 1 on GigabitEthernet0/1 VLAN999.

%SPANTREE-2-BLOCK_PVID_LOCAL: Blocking GigabitEthernet0/1 on VLAN0999. Inconsistent local vlan.

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/2 (999), with S3 GigabitEthernet0/2 (1).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/1 (999), with S2 GigabitEthernet0/1 (1).

e. On S2 and S3, configure VLAN 999 as the native VLAN.
f. Verify trunking is successfully configured on all the switches.

Part 2: Configure and Verify VTP

S1 will be configured as the VTP server and S2 will be configured as a VTP client. All the switches will be configured to be in the VTP domain CCNA and use the VTP password cisco.
VLANs can be created on the VTP server and distributed to other switches in the VTP domain. In this part, you will create 3 new VLANs on the VTP server, S1. These VLANs will be distributed to S2 using VTP. Observe how the transparent VTP mode behaves.

Step 1: Configure S1 as a VTP server.
Configure S1 as the VTP server in the CCNA domain with the password cisco.

a. Configure S1 as a VTP server.

S1#config t
Enter configuration commands, one per line. End with CNTL/Z.
Device mode already VTP SERVER.
S1(config)#
%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/2 (999), with S3 GigabitEthernet0/2 (1).

b. Configure CCNA as the VTP domain name, Configure cisco as the VTP password.

S1(config)#vtp domain CCNA
Changing VTP domain name from NULL to CCNA
S1(config)#

S1(config)#vtp password cisco
Setting device VLAN database password to cisco
S1(config)#

Step 2: Verify VTP on S1.

a. Use the show vtp status command on the switches to confirm that the VTP mode and domain are configured correctly.

S1(config)#do show vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 7

MD5 digest : 0x8C 0x29 0x40 0xDD 0x7F 0x7A 0x63 0x17
Local updater ID is 192.168.99.1 on interface Vl99 (lowest numbered VLAN interface found)
S1(config)#
%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/2 (999), with S3 GigabitEthernet0/2 (1).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/1 (999), with S2 GigabitEthernet0/1 (1).

b. To verify the VTP password, use the show vtp password command.

S1(config)#
S1(config)#do show vtp password
VTP Password: cisco
S1(config)#

Step 3: Add S2 and S3 to the VTP domain.


Configure S2 as a VTP client with CCNA as the VTP domain name and cisco as the VTP password. Remember that VTP domain names are case sensitive.

a. Configure S2 as a VTP client in the CCNA VTP domain with the VTP password cisco.

S2#config t
Enter configuration commands, one per line. End with CNTL/Z.

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/1 (1), with S1 GigabitEthernet0/1 (999).
p

S2(config)#vtp mode client
Setting device to VTP CLIENT mode.
S2(config)#
S2(config)#vtp domain CCNA
Changing VTP domain name from NULL to CCNA
S2(config)#

b. To verify the VTP password, use the show vtp password command.

S2(config)#
S2(config)#do show vtp password
The VTP password is not configured.
S2(config)#

c. Configure S3 to be in the CCNA VTP domain with the VTP password cisco. Switch S3 will be set in VTP transparent mode.

S3(config)#
S3(config)#vtp mode transparent
Setting device to VTP TRANSPARENT mode.
S3(config)#
S3(config)#vtp domain CCNA
Domain name already set to CCNA.
S3(config)#
S3(config)#vtp password cisco
Setting device VLAN database password to cisco
S3(config)#

Step 4: Create more VLANs on S1.

a. On S1, create VLAN 10 and name it Red.

S1(config)#vlan 10
S1(config-vlan)#name Red

S1(config-vlan)#
S1(config-vlan)#vlan 20
S1(config-vlan)#name Blue
S1(config-vlan)#vlan 30
S1(config-vlan)#name Yello
%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/2 (999), with S3 GigabitEthernet0/2 (1).

%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/1 (999), with S2 GigabitEthernet0/1 (1).
w
S1(config-vlan)#
S1(config-vlan)#vlan 30
S1(config-vlan)#name Yellow
S1(config-vlan)#

c. Confirm configuration changes using the show vtp status command on S1 and S2 to confirm that the VTP mode and domain are configured correctly. Output for S2 is shown here:

S2(config)#
S2(config)#do show vtp status
VTP Version : 2
Configuration Revision : 0
Maximum VLANs supported locally : 255
Number of existing VLANs : 7

MD5 digest : 0xB8 0x97 0x2F 0xFE 0xA9 0x9D 0x7E 0xFC
S2(config)#

Step 6: Assign VLANs to Ports

Use the switchport mode access command to set access mode for the access links. Use the switchport access vlan vlan-id command to assign a VLAN to an access port.

S2(config)#int range f0/1 – 8
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 10
S2(config-if-range)#int f0/9 – 16
%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/1 (1), with S1 GigabitEthernet0/1 (999).

S2(config-if-range)#
S2(config-if-range)#int range f0/9 – 16
S2(config-if-range)#switchport mode access
S2(config-if-range)#switchport access vlan 20
S2(config-if-range)#int range fa0/17 – 24
S2(config-if-range)#
%CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on GigabitEthernet0/1 (1), with S1 GigabitEthernet0/1 (999).
mo
S2(config-if-range)#switchport mode access
S2(config-if-range)#sw
S2(config-if-range)#switchport access vlan 30
S2(config-if-range)#

Step 7: Verify end to end connectivity.

a. From PC0 ping PC5.
b. From PC1 ping PC4.
c. From PC2 ping PC3.

By Admin